Составить программу, позволяющую в одномерном массиве, состоящем из N вещественных элементов, вычислить: наименьший из элементов массива, принадлежащих отрезку [a,b]
Составить программу, позволяющую в одномерном массиве, состоящем из N вещественных элементов, вычислить: наименьший из элементов массива, принадлежащих отрезку [a,b]
Ответ(ы) на вопрос:
Pascal
const n = 20;
var
a,b,min : real;
m : array [1..n] of real;
i : integer;
begin
// формирова массива не пишу
readln (a,b);
min := b;
for i := 1 to n do
if (m[i]=a ) and (m[i] <=b)
then
min := m[i];
writeln (min:3:2);
end.
Программа будет работать корректно, если в массиве есть хотя бы один элемент, попадающий в диапозон [a..b].
Не нашли ответ?
Похожие вопросы