Составить программу, решающую следующую задачу: Дано число а. Не пользуясь никакими другими операциями, кроме умножения, получить: [latex] a^{8} [/latex] за 3 операции.

Составить программу, решающую следующую задачу: Дано число а. Не пользуясь никакими другими операциями, кроме умножения, получить: [latex] a^{8} [/latex] за 3 операции.
Гость
Ответ(ы) на вопрос:
Гость
[latex]\displaystyle x=a^8={((a^2)^2})^2={((a\times a)^2)}^2 \\ a_1:=(a\times a); \ a_2:=(a_1\times a_1); \ a_3:=(a_2\times a_2) [/latex] var   x,a,b:longint;   begin   a:=3;   a:=a*a;   a:=a*a;   x:=a*a;   Writeln('3 в степени 8 равно ',x) end. Тестовое решение: 3 в степени 8 равно 6561
Не нашли ответ?
Ответить на вопрос
Похожие вопросы