. Составить программу, решающую следующую задачу: Вы продавец, и у Вас имеются гири весом  1, 2, 5 кг. Наберите минимальное количество гирь для взвешивания  N кг.Язык программирования-паскаль

. Составить программу, решающую следующую задачу: Вы продавец, и у Вас имеются гири весом  1, 2, 5 кг. Наберите минимальное количество гирь для взвешивания  N кг.Язык программирования-паскаль
Гость
Ответ(ы) на вопрос:
Гость
var N, a, b: integer; begin      readln(N);      a := N div 5;      N := N mod 5;      b := N div 2;      WriteLn(a, 'x5, ', b, 'x2, ', N mod 2, 'x1'); end. Вот так, делением можно)
Не нашли ответ?
Ответить на вопрос
Похожие вопросы