Составить программу суммирования натуральных чисел 1...n пока их сумма не превысит величину h. Вывести на экран последнее слагаемое и сумму
Составить программу суммирования натуральных чисел 1...n пока их сумма не превысит величину h. Вывести на экран последнее слагаемое и сумму
Ответ(ы) на вопрос:
readln(n,h);
for i:=1 to n do begin
s:=s+i;
if s>h then
break;
end;
writeln(i,s);
uses crt;
var n,h,i,sum:integer;
begin
read(n,h);
while sum<=h do
begin
sum+=i;
i+=1;
end;
writeln(i-1,' ',sum-i);
end.
Не нашли ответ?
Похожие вопросы