Составить программу в Pascal, которая вводит строку символов, удаляя все символы, не являющиеся латинскими буквами и затем выводит результаты.
Составить программу в Pascal, которая вводит строку символов, удаляя все символы, не являющиеся латинскими буквами и затем выводит результаты.
Ответ(ы) на вопрос:
Гость
//PascalABC.NET 3.2 сборка 1318
var
s: string;
i,k: integer;
begin
readln(s);
i:=1;
k:=length(s);
while i<>k do
begin
k:=length(s);
if (upcase(s[i]) < 'A') or (upcase(s[i]) > 'Z') then
begin
delete(s, i, 1);
i:=i-1;
end;
i:=i+1;
end;
writeln(s);
end.
Пример ввода:
Gleb1Kosyrev Sample Текст, Pointer Symbol is ^
Пример вывода:
GlebKosyrevSamplePointerSymbolis
Не нашли ответ?
Похожие вопросы