Составить программу в паскаль. Вычислить и запомнить значения функции Yi=X , если Xi меньше 0 Yi=0 , если Xi=0 -1 , если Xi≤0 где Xi - элементы массива из 20 элементов

Составить программу в паскаль. Вычислить и запомнить значения функции Yi=X , если Xi<0 Yi=0 , если Xi=0 -1 , если Xi≤0 где Xi - элементы массива из 20 элементов
Гость
Ответ(ы) на вопрос:
Гость
# include using namespace std; int main() { int x[20], y[20]; int i, n; cin >> n; for(i = 1; i <= n; ++i) cin >> x[i] >> y[i]; if(x[i] > 0) y[i] = x[i]; if(y[i] == 0)  x[i] = 0; if(x[i] <= 0) puts('-1'); else cout << x[i] << ' ' << y[i]; return 0; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы