Составить программу, включающую меню из четырех пунктов: 1.Создать текстовый файл из пяти строк-предложений. 2.Вывести содержимое файла на экран. 3.Вывести на экран количество слов, содержащих цифры. 4.Выход. Первые три пункта ...
Составить программу, включающую меню из четырех пунктов: 1.Создать текстовый файл из пяти строк-предложений. 2.Вывести содержимое файла на экран. 3.Вывести на экран количество слов, содержащих цифры. 4.Выход. Первые три пункта меню реализовать в процедурах, которые поместить в модуль.
На делфи.
Ответ(ы) на вопрос:
Гость
{ Запись 5 строк в файл }
procedure TForm1.Button1Click(Sender: TObject);
var outfile: TextFile;
begin
AssignFile(outfile, 'outfile.txt')
;Rewrite(outfile);
writeln(outfile, 'Привет из Delphi');
writeln(outfile, 'Моя программа работает, и выводит '
+'данный текст, чтобы доказать это...');
writeln(outfile, '3. Треться строка');
writeln(outfile, '234 четвертая');
writeln(outfile, 'Пятая строка');
CloseFile(outfile);
end;
// вывод на экран точнее в мемо или лист бокс
procedure TForm1.Button2Click(Sender: TObject);
begin
// выводим в мемо
Memo1.Lines.LoadFromFile('outfile.txt');
// либо в лист бокс как тебе лучше
ListBox1.Items.LoadFromFile('outfile.txt');
end;
// кнопка для закрытия
procedure TForm1.Button3Click(Sender: TObject);
begin
Close;
end;
// событие onClose
procedure TForm1.FormClose(Sender: TObject; var CloseAction: TCloseAction);
begin
if MessageDlg('Вы точно хотите выйти?', mtConfirmation, mbOkCancel,0)= mrOk then begin
CloseAction:= caFree;
end
else begin
CloseAction:= caNone;
end;
end;
ЗДЕСЬ!
outfile.txt - это ваш файл(может создаваться автоматически
ЧТО НУЖНО СДЕЛАТЬ?
1. Закинуть на форму 3 кнопки
2. Закинуть ListBox или Memo
3. В событиях формы в инспекторе объектов (Инспетор Объектов/ События/ onClose) в onClose выбрать процедуру FormClose
Не нашли ответ?
Похожие вопросы