Составить программу вычисления количества трёхзначных чисел которые не кратны 5 С ПОМОЩЬЮ WHILE
Составить программу вычисления количества трёхзначных чисел которые не кратны 5
С ПОМОЩЬЮ WHILE
Ответ(ы) на вопрос:
var i,k:integer;
begin;
i:=100;
while i<>1000 do
begin;
if i mod 5<>0 then k:=k+1;
inc(i);
end;
writeln(k);
end.
Заметим, что всего имеется 900 трехзначных чисел - от 100 до 999.
Если посчитать, сколько среди них чисел, кратных пяти, то вычтя его из 900, получим искомый ответ.
Первое число, кратное 5, это 100. А все остальные получаются путем последовательного прибавления числа 5.
// PascalABC.Net 3.0, сборка 1064
var
i,n:integer;
begin
n:=0; i:=100;
while i<1000 do begin Inc(n); i:=i+5 end;
Writeln('Количество чисел равно ',900-n)
end.
Результат выполнения программы:
Количество чисел равно 720
Не нашли ответ?
Похожие вопросы