Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей. В результате вывести итоговую стоимость покупки...
Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей. В результате вывести итоговую стоимость покупки и размер предоставленной скидки.
Ответ(ы) на вопрос:
Гость
var s:integer;
begin
write('Стоимость покупки = '); readln(s);
if s>1000
then writeln('Скидка 5% (',s*0.05,' руб.), необходимо заплатить ',s*0.95)
else if s>500
then writeln('Скидка 3% (',s*0.03,' руб.), необходимо заплатить ',s*0.97)
else writeln('Скидки нет');
end.
Пример:
Стоимость покупки = 600
Скидка 3% (18 руб.), необходимо заплатить 582
Не нашли ответ?
Похожие вопросы