Составить программу вычисления суммы квадратов и квадрата суммы натуральных чисел от 1 до 50
Составить программу вычисления суммы квадратов и квадрата суммы натуральных чисел от 1 до 50
Ответ(ы) на вопрос:
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
Writeln('Квадрат суммы [1;50]= ',sqr(Range(1,50).Sum));
Writeln('Сумма квадратов [1;50]= ',Range(1,50).Select(x->x*x).Sum);
end.
Тестовое решение:
Квадрат суммы [1;50]= 1625625
Сумма квадратов [1;50]= 42925
Не нашли ответ?
Похожие вопросы