Составить программу вычисления суммы цифр двухзначного числа "a".Значение "а",введите с клавиатуры.ПОМОГИТЕ!!!Срочно надо(Буду вам очень признательна *_*
Составить программу вычисления суммы цифр двухзначного числа "a".Значение "а",введите с клавиатуры.ПОМОГИТЕ!!!Срочно надо(Буду вам очень признательна *_*
Ответ(ы) на вопрос:
Гость
должно работать и для двухзначного и для 3ехзначного и для 99999значного
var
a,sum:integer;
begin
readln(a);
while a>0 do
begin
sum:=sum+a mod 10;
a:=a div 10;
end;
writeln(sum);
end.
Гость
Pascal ABC
Var
A:integer;
Begin
Write('A = ');Read(A);
Write(A div 10,'+',A mod 10,' = ',(A div 10)+(A mod 10))
End.
Не нашли ответ?
Похожие вопросы