Составить программу, выполняющую следующие действия: Вводит с клавиатуры строку 'Bloomedapplesandpears' (Расцветали яблони и груши). Определяет номер позиции, в которой находится буква r в исходной строке. Меняет местами слова ...
Составить программу, выполняющую следующие действия:
Вводит с клавиатуры строку 'Bloomedapplesandpears' (Расцветали яблони и груши).
Определяет номер позиции, в которой находится буква r в исходной строке.
Меняет местами слова ' Bloomed ' и 'pears'.
Удаляет из исходной строки подстроку 'applesand '.
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
var s:=ReadlnString('>');
var w1:='Bloomed';
var w2:='pears';
var w3:='applesand';
var i:=Pos('r',s);
Writeln('Позиция r: ',i);
i:=Pos(w2,s);
s:=s[:i]+w1;
s:=w2+s[w1.Length+1:];
Writeln(s);
i:=Pos(w3,s);
Delete(s,i,w3.Length);
Writeln(s)
end.
Тестовое решение
> Bloomedapplesandpears
Позиция r: 20
pearsapplesandBloomed
pearsBloomed
Гость
//Pascal ABC.NET 3.1 сборка 1256
Var
s,s1:string;
begin
readln(s);
writeln(pos('r',s));
s1:='Bloomed';
delete(s,1,length(s1));
insert('pears',s,1);
delete(s,length(s)-length('pears')+1,length(s1));
insert(s1,s,length(s)+1);
writeln(s);
delete(s,pos('applesand',s),length('applesand'));
writeln(s);
end.
Вывод:
20
pearsapplesandBloomed
pearsBloomed
Не нашли ответ?
Похожие вопросы