Составить программу выводящую на экран все делители на число х.(число х вводится с клавиатуры)
Составить программу выводящую на экран все делители на число х.(число х вводится с клавиатуры)
Ответ(ы) на вопрос:
program ml;
uses crt;
var x,i:integer;
w,l:real;
begin
clrscr;
readln(x);
L:=x;
for i:=1 to x do begin
w:=w+1;
l:=x/w;
if frac(l) = 0 then writeln(l:2:0);
end;
readkey;
end.
Не нашли ответ?
Похожие вопросы