Составить программу,которая: а)из слов "программа"составляет слова: " грамм", "рога", "гора"; б) из слов " страх", "белка", "цыпленок" получает слово"столбец"; в)считает, сколько раз в тексте, заданном с клавиатуры, встречается...
Составить программу,которая:
а)из слов "программа"составляет слова: " грамм", "рога", "гора";
б) из слов " страх", "белка", "цыпленок" получает слово"столбец";
в)считает, сколько раз в тексте, заданном с клавиатуры, встречается, фрагмент "ба".
Ответ(ы) на вопрос:
Program z1; var s, s1, s2, s3, s4, s5, s6, s7, s8:string; begin s:='программа'; s1:=copy (s, 4, 4); s4:=copy (s, 2, 3); s5:=copy (s, 2, 1); s2:=s4+s5; s6:=copy (s, 4, 1); s7:=copy (s, 3, 1); s8:=copy (s, 5, 2); s3:=s6+s7+s8; writeln (s1, s2, s3); end. Посмотри, это пункт а. Если то, что нужно, сделаю остальные.. Program z1; var s, s1, s2, s3, st, o, l, be, c: string; begin s1:='страх'; s2:='белка'; s3:='цыпленок'; st:=copy (s1, 1, 2); o:=copy (s3, 7, 1); l:=copy (s2, 3, 1); be:=copy (s2, 1, 2); c:=copy (s3, 1, 1); s:=st+o+l+be+c; writeln (s); end.
Не нашли ответ?
Похожие вопросы