Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В и С. Если они не равны, то замените все числа наибольшим из них и выведите результаты на экран. Иначе, найдите и выведите сумму квадратов эт...
Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В и С. Если они не равны, то замените все числа наибольшим из них и выведите результаты на экран. Иначе, найдите и выведите сумму квадратов этих чисел.
Ответ(ы) на вопрос:
program abc;
var a,b,c:integer;
begin
readln(a,b,c);
if ((a=b) and (b=c) and (c=a)) then writeln(sqr(a)+sqr(b)+sqr(c))
else if (a>b) and (b>c) then begin b:=a; c:=a; writeln('a=',a,' b=',b,' c=',c) end
else if (b>a) and (c