Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если А больше В больше C больше 0, то замените все числа их квадратами и выведите результаты на экран. Если они отрицательны и не равны...
Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если А>В>C>0, то замените все числа их квадратами и выведите результаты на экран. Если они отрицательны и не равны между собой, то каждое число замените наибольшим из них и выведите результаты. Иначе, найдите и выведите их сумму.
Ответ(ы) на вопрос:
Program asd;
uses crt;
var a,b,c,max:integer; r:real;
begin
Write('Введите число A: ');
Readln(a);
Write('Введите число B: ');
Readln(b);
Write('Введите число C: ');
Readln(c);
If a>=b then max:=a
else
max:=b;
If c>max then
max:=c;
r:=a+b+c;
If (A>B) and (B>C) and (C>0) then
Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);
If (A<0) and (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A) then
begin
A:=max;
B:=max;
C:=max;
Writeln('A= ',a,' B= ',b,' C= ',c);
end
else
Writeln('Symma: ',r);
end.
Не нашли ответ?
Похожие вопросы