Составьте программу для решения задачи: даны две точки, заданные своими координатами. Определить , какая из них находится ближе к началу координат.

Составьте программу для решения задачи: даны две точки, заданные своими координатами. Определить , какая из них находится ближе к началу координат.
Гость
Ответ(ы) на вопрос:
Гость
Расстояние от точки до начала координат находится как длина гипотенузы прямоугольного треугольника, катетами которого являются координаты точки. Поскольку нам нужны не сами расстояния, а лишь сравнить их, то можно сравнивать квадраты, чтобы не извлекать корня.[latex]r_i^2=x_i^2+y_i^2[/latex] // PascalABC.NET 3.0, сборка 1088 var   x1,x2,y1,y2,r1,r2:real; begin   Write('Введите координаты первой точки: '); Read(x1,y1);   Write('Введите координаты второй точки: '); Read(x2,y2);   r1:=sqr(x1)+sqr(y1); r2:=sqr(x2)+sqr(y2);   if r1>r2 then Writeln('Ближе вторая точка')   else     if r1
Не нашли ответ?
Ответить на вопрос
Похожие вопросы