Составьте программу к следующей задаче:Ученик начал решать задачи данного урока программирования, когда электронные часы показывали h1 часов и min1 минут, а закончил, когда было h2часов и min2 минут. Составьте программу, позвол...

Составьте программу к следующей задаче: Ученик начал решать задачи данного урока программирования, когда электронные часы показывали h1 часов и min1 минут, а закончил, когда было h2часов и min2 минут. Составьте программу, позволяющую определить, сколько времени (в часах и минутах) ученик решал эти задачи.
Гость
Ответ(ы) на вопрос:
Гость
Используется время одних суток. var h1,min1,h2,min2,h,min,m:integer; begin write('h1, m1: '); readln(h1,min1); write('h2, m2: '); readln(h2,min2); m:=(h2*60+min2)-(h1*60+min1); h:=m div 60; min:=m mod 60; writeln('h = ',h,' min = ',min); end. Пример: h1, m1: 1 20 h2, m2: 3 15 h = 1 min = 55
Не нашли ответ?
Ответить на вопрос
Похожие вопросы