Составьте программу ,которая формирует массив из шестнадцати случайных чисел от -20 до 20 и находит индексы четных элементов
Составьте программу ,которая формирует массив из шестнадцати случайных чисел от -20 до 20 и находит индексы четных элементов
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1344 от 22.11.2016
// Внимание! В других версиях работа не гарантируется!
begin
var a:=ArrRandom(16,-20,20); a.Println;
Write('Индексы четных элементов: ');
a.Select((x,i)->(x,i+1)).Where(x->x[0].IsEven).Select(x->x[1]).Println;
end.
Пример
-7 -6 -11 6 -9 11 -6 -15 2 2 10 20 2 16 9 0
Индексы четных элементов: 2 4 7 9 10 11 12 13 14 16
Не нашли ответ?
Похожие вопросы