Составьте программу, которая формирует массив, содержащий 15 случайныхцелых чисел, принадлежащих промежутку [0;8] и преобразует элементы массива по следующему правилу: к четному числу прибавляет 1, а нечетное умножает на 2.
Составьте программу, которая формирует массив, содержащий 15 случайныхцелых чисел, принадлежащих промежутку [0;8] и преобразует элементы массива по следующему правилу: к четному числу прибавляет 1, а нечетное умножает на 2.
Ответ(ы) на вопрос:
Program Frank;
const n=15;
Type mas=array[1..n] of integer;
var a:mas;i:integer;
begin
for i:=1 to n do begin
a[i]:=random(8);
write(' ',a[i]);
end;
for i:=1 to n do begin
if a[i] mod 2=0 then a[i]:=a[i]+1
else a[i]:=a[i]*2;
write(' Получили ',a[i]);
end;
end. end.
Не нашли ответ?
Похожие вопросы