Составьте программу, которая позволяет ввести элементы массива а [1...10] с клавиатуры и выводит на экран количество отрицательных элементов и их индексы.

Составьте программу, которая позволяет ввести элементы массива а [1...10] с клавиатуры и выводит на экран количество отрицательных элементов и их индексы.
Гость
Ответ(ы) на вопрос:
Гость
Паскаль. var a:array [1..10] of integer; begin writeln(' Введите 10 элементов массива через пробел'); i:=1; repeat read(a[i]); i:=i+1; until i>10; k:=0; for i:=1 to 10 do if a[i]<0 then begin k:=k+1; write(i, '  '); end; writeln; if k=0 then write('В массиве нет отрицательных элементов') else write('В массиве ',k,' отрицательных элементов'); readln; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы