Составьте программу которая позволяет ввести строки s, затем после каждой буквы "а" вставляет пробел. Pascal ABC, срочно

Составьте программу которая позволяет ввести строки s, затем после каждой буквы "а" вставляет пробел. Pascal ABC, срочно
Гость
Ответ(ы) на вопрос:
Гость
Вот программа: var s,s1:string; i:integer; begin writeln('Введите строку:'); readln(s); s1:=''; for i:=1 to length(s) do  if s[i]='а' then s1:=s1+s[i]+' ' else s1:=s1+s[i]; writeln(s1); end. Здесь буква "а" - русская
Гость
Function InsSpace(S : String) : String; Begin   If Length(S)>0 then     If S[1]='а' then InsSpace:=S[1]+' '+InsSpace(Copy(S,2,Length(S)-1))     else InsSpace:=S[1]+InsSpace(Copy(S,2,Length(S)-1))   else InsSpace:=''; end; Var St : String; Begin   Readln(St);   Writeln(InsSpace(St)); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы