Составьте программу, которая вычисляет оптимальный вес, сравнивает его с реальным и выдаёт рекомендацию о необходимости поправиться или похудеть (с указанием, на сколько кг нужно поправиться или похудеть). Оптимальный вес вычи...
Составьте программу, которая вычисляет оптимальный вес, сравнивает его с реальным и выдаёт рекомендацию о необходимости поправиться или похудеть (с указанием, на сколько кг нужно поправиться или похудеть).
Оптимальный вес вычисляется по формуле:
рост (в см) – 100.
Ответ(ы) на вопрос:
Программа ниже.
Код:
var
rost, ves, opt: integer;
begin
write('Введите рост: ');
readln(rost);
opt := rost - 100;
write('Введите вес: ');
readln(ves);
if ves < opt then
writeln('Вам нужно поправиться на ', opt - ves, ' кг.');
if ves > opt then
writeln('Вам нужно похудеть на ', ves - opt, ' кг.');
if ves = opt then
writeln('Ваш вес оптимальный');
end.
Не нашли ответ?
Похожие вопросы