Составьте программу, которая вычисляет сумму первых десяти нечетных натуральных чисел с помощью оператора For...to.
Составьте программу, которая вычисляет сумму первых десяти нечетных натуральных чисел с помощью оператора For...to.
Ответ(ы) на вопрос:
Гость
var i,s,k:integer;
begin
for i:=1 to 100 do
begin
if (k<10) and (i mod 2=1)
then
begin
s:=s+i;
k:=k+1;
end;
end;
writeln(s);
end.
//Хотя совершено глупо в данной ситуации использовать for куда лучше while
Гость
var
i, s: integer;
begin
for i := 1 to 10 do
s := s + (2 * i - 1);
writeln(s);
end.
Не нашли ответ?
Похожие вопросы