Составьте программу которая выводит на экран из всех трёхзначных чисел, только те у которых квадрат первой цифры равен сумме двух остальных.
Составьте программу которая выводит на экран из всех трёхзначных чисел, только те у которых квадрат первой цифры равен сумме двух остальных.
Ответ(ы) на вопрос:
Гость
var
i: integer;
begin
for i:=100 to 999 do
if (sqr(i div 100) = i mod 10 + i div 10 mod 10) then
writeln(i);
end.
Гость
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
for var i:=100 to 999 do begin
var d1:=i div 100;
var d2:=(i div 10) mod 10;
var d3:=i mod 10;
if sqr(d1)=d2+d3 then Print(i)
end;
Println
end.
Тестовое решение:
101 110 204 213 222 231 240 309 318 327 336 345 354 363 372 381 390 479 488 497
Не нашли ответ?
Похожие вопросы