Составьте программу, которая заполняет массив a[1..8] случайными числами в диапазоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму элементов массива с нечётными значениями

Составьте программу, которая заполняет массив a[1..8] случайными числами в диапазоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму элементов массива с нечётными значениями
Гость
Ответ(ы) на вопрос:
Гость
Program z; var a:array[1..8] of integer; i,k,s:integer; begin for i:=1 to 8 do begin a[i]:=random(9)+1; end; for i:=1 to 8 do begin if a[1] mod 2=0 then k:=k+1 else s:=s+a[i]; end; writeln('Summa=',s); writeln('Kol-vo=',k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы