Составьте программу находящую количество делителей числа x. Число x введите с клавиатуры. Пример ввода: 12. Пример вывода: 6

Составьте программу находящую количество делителей числа x. Число x введите с клавиатуры. Пример ввода: 12. Пример вывода: 6
Гость
Ответ(ы) на вопрос:
Гость
Берём число и просто циклом проходимся до его половины. Если этот счётчик кратен числу, то прибавляем к главному счётчику 1. int main () { int a=0; //Вводимое число int c=0; //Счётчик cin >> a; for (int i = 0; i < a/2+1; ++i) { if(a%i==0)c++; } cout << c; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы