Составьте программу нахождения наименьшего натурального N-значного числа X (Х больше =10), равному утроенному произведению своих цифр. pascal
Составьте программу нахождения наименьшего натурального N-значного числа X (Х>=10), равному утроенному произведению своих цифр. pascal
Ответ(ы) на вопрос:
Максимальное число, составленное из утроенного произведения цифр будет
9*3*N - не может быть больше 54, т.е.
N может быть только 1 или 2. По условию х>=10 -> N=2 (N -порядок числа).
Поэтому искать нужно среди чисел от 11 до 54. Решение - число 15.
var n,m: integer;
begin
write('n = '); readln(n);
if n=2 then
begin m:=11;
repeat
if (m mod 10)*(m div 10)*3=m then
begin
writeln('число: ',m);
m:=55;
end;
m:=m+1;
until m>54;
end
else writeln('нет решения');
end.
Не нашли ответ?
Похожие вопросы