Составьте программу определения количества четных и нечетных цифр в записи данного натурально числа

Составьте программу определения количества четных и нечетных цифр в записи данного натурально числа
Гость
Ответ(ы) на вопрос:
Гость
var n,k1,k2:integer; begin write('n = '); readln(n); k1:=0; k2:=0; while n>0 do  begin  if n mod 2=0 then k1:=k1+1 else k2:=k2+1;  n:=n div 10;  end; writeln('Четных цифр - ',k1,', нечетных - ',k2); end. Пример: n = 14568 Четных цифр - 3, нечетных - 2
Гость
Program n1; var a,kn,kh: longint; begin kn:=0; kh:=0; readln(a); while a>0 do begin if (a mod 10) mod 2=0 then kh:=kh+1 else kn:=kn+1; a:= a div 10; end; writeln('кол-во четных: ',kh); writeln('нечетных: ',kn); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы