Составьте программу, определяющую, является ли данное число кратным 4 Составьте программу, заменяющую большее из двух данных чисел удвоенным произведением, а меньшее - полусуммой этих чисел. Помогите пожалуйста!!!!
Составьте программу, определяющую, является ли данное число кратным 4
Составьте программу, заменяющую большее из двух данных чисел удвоенным произведением, а меньшее - полусуммой этих чисел.
Помогите пожалуйста!!!!
Ответ(ы) на вопрос:
program n1;
var
x:integer;
begin
writeln('Введите число'); readln(x);
if (x mod 4=0) then writeln('Является') else writeln('Не является');
end.
program n2;
var
a,b:integer;
begin
writeln('Введите первое число'); readln(a);
writeln('Введите второе число'); readln(b);
if a>b then writeln(a*b*2,' ',(a+b)/2) else writeln((a+b)/2,' ',a*b*2);
end.
Не нашли ответ?
Похожие вопросы