Составьте программу с использованием структуры данных список. Условие: Вычислить и вывести на экран среднее арифметическое элементов списка, стоящих на четных местах. Входные данные: N – количество элементов списка (целого типа...
Составьте программу с использованием структуры данных список.
Условие: Вычислить и вывести на экран среднее арифметическое элементов списка, стоящих на четных местах. Входные данные: N – количество элементов списка (целого типа); сами элементы списка. Выходные данные: вычисленное значение.
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.0, сборка 1088
begin
var n:=ReadInteger('Количество элементов в списке: ');
var L:=new List;
var t:integer;
Writeln('Вводите чеез пробел целочисленные элементы списка');
for var i:=1 to n do begin
t:=ReadInteger; L.Add(t)
end;
var i:=1;
var s:=0;
while i<=n-1 do begin s+=L[i]; Inc(i,2) end;
Writeln('Среднее арифметическое с четных мест равно ',
s/(n div 2):0:3)
end.
Тестовое решение:
Количество элементов в списке: 5
Вводите чеез пробел целочисленные элементы списка
-6 12 57 32 8
Среднее арифметическое с четных мест равно 22.000
Не нашли ответ?
Похожие вопросы