Составьте программу в паскале. Поиск максимального 3-х чисел. Учесть случай, когда а=в=с (вывести сообщение "числа равны"). Блок-схема обязательна.

Составьте программу в паскале. Поиск максимального 3-х чисел. Учесть случай, когда а=в=с (вывести сообщение "числа равны"). Блок-схема обязательна.
Гость
Ответ(ы) на вопрос:
Гость
var   a:array [1..3] of real;   max: real;   i,check:integer; begin   writeln('Поиск максимального 3-х чисел');   writeln('Введите значения 3-х чисел');   for i:= 1 to 3 do     readln(a[i]);   max:=a[1];   check:=1;   for i:=2 to 3 do   begin     if a[i]>max then       max:=a[i]     else if a[i]=max then       check:=check+1;    end; if check=3 then   writeln('Все числа равны') else      writeln('Max=',max) end.
Гость
//Pascal ABC.NET v3.0 сборка 1111 //"Школьный" вариант, первая блок-схема Var  a,b,c:integer; begin  read(a,b,c);  if (a=b) and (b=c) then writeln('=') else   begin;  if a>b then   if a>c then writeln(a);  if b>a then   if b>c then writeln(b);  if c>a then    if c>b then writeln(c);   end; end. //Вариант для любителей оккультизма, вторая блок-схема begin  var se:=ReadArrReal(3);  if se.Sum()/se.Average()=se.Average() then writeln('=') else writeln(se.Max); end.  Пример ввода: 3 3 3 Пример вывода: =
Не нашли ответ?
Ответить на вопрос
Похожие вопросы