Составьте программу вычисления функции:у=[latex] \left \{ {{-2 x^{2} +x +1,x \leq 0} \atop {-2 x^{2} + 3, x больше 0}} \right. [/latex]

Составьте программу вычисления функции: у=[latex] \left \{ {{-2 x^{2} +x +1,x \leq 0} \atop {-2 x^{2} + 3, x>0}} \right. [/latex]
Гость
Ответ(ы) на вопрос:
Гость
var   x: real; //Пусть будут (почти) любые числа begin   readln(x); // вводим   writeln(-2 * sqr(x) + (x <= 0 ? x + 1 : 3)); //Тернары - добро, ибо код меньше:                                                            //(условие ? вывод при истине : вывод иначе) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы