Составьте программу вычисления количества трёхзначных чисел, у которых сумма цифр является чётным числом.

Составьте программу вычисления количества трёхзначных чисел, у которых сумма цифр является чётным числом.
Гость
Ответ(ы) на вопрос:
Гость
uses crt; var i,s,c,k,b:integer; begin s:=0; k:=0; for i:=100 to 999 do begin b:=i; repeat c:=b mod 10; s:=s+c; b:= b div 10; until b=0; if (s mod 2=0) then inc(k); end; writeln(k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы