Составьте программу вычисления суммы всех двузначных чисел, имеющих в своем составе цифру 1 или 3. ( программа для Паскаля, 9 класс и function не проходили, поэтому как можно проще и я так думаю с var или тому подобное) очень н...
Составьте программу вычисления суммы всех двузначных чисел, имеющих в своем составе цифру 1 или 3. ( программа для Паскаля, 9 класс и function не проходили, поэтому как можно проще и я так думаю с var или тому подобное) очень нужно
Ответ(ы) на вопрос:
var s,i:integer;
begin
s:=0;
for i:=10 to 93 do
begin
if (i mod 10 = 1) or (i div 10 = 1) or (i mod 10 = 3) or (i div 10 = 3) then
s:=s+i;
end;
writeln('Сумма всех двузначных чисел, имеющих в составе 3 или 1 равна ', s)
end.
Не нашли ответ?
Похожие вопросы