Составьте программу, вычисляющую, сколько раз в строке X встречается слово Y. Строк

Составьте программу, вычисляющую, сколько раз в строке X встречается слово Y. Строку X и слово Y введите с клавиатуры.
Гость
Ответ(ы) на вопрос:
Гость
Var x,y,z:string; k,p,l:integer; begin writeln('Введите строку:'); readln(x); writeln('Введите слово:'); readln(y); z:=x; k:=0; l:=length(y); p:=pos(y,x); while p>0 do  begin  k:=k+1;  delete(z,p,l);  p:=pos(y,z);  end; writeln('k = ',k); end. Пример: Введите строку: мама мыла раму, мама мыла окно. Введите слово: мама k = 2
Не нашли ответ?
Ответить на вопрос
Похожие вопросы