Составьте программу записывающую в файл одномерный массив случайных чисел, а затем считывающую его с диска и выполняющую запись четных элементов в другой файл (на Паскале)

Составьте программу записывающую в файл одномерный массив случайных чисел, а затем считывающую его с диска и выполняющую запись четных элементов в другой файл (на Паскале)
Гость
Ответ(ы) на вопрос:
Гость
program untitled; var t,t2:text;     i,a:integer;     m:array [1..50] of integer; begin randomize; assign(t,'output.txt'); assign(t2,'output2.txt'); rewrite(t);  for i:=1 to 50 do begin  m[i]:=random(50);  writeln(t,m[i]); end;  reset(t); rewrite(t2); for i:=1 to 50 do begin  readln(t,a);  if a mod 2=0 then   writeln(t2,a);  end;  close(t); close(t2); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы