Составьте программу,которая формирует массив из 15 случайных целых цифр от -20 до 20 и чётные цифры делит на 2,а нечётные-умножает на 3

Составьте программу,которая формирует массив из 15 случайных целых цифр от -20 до 20 и чётные цифры делит на 2,а нечётные-умножает на 3
Гость
Ответ(ы) на вопрос:
Гость
На каком языке нужна программа?  Пример на Paskal:  program zadacha;  var massiv: array [1..15] of integer; i:byte; massiv2:array [1..15] of real;  begin  randomize;  write('Isxodnij massiv: ');  for i:=1 to 15 do  begin  massiv:=random(41)-20;  write(massiv,' ');  end;  writeln;  writeln('Massiv posle preobrazovanij: ');  for i:=1 to 15 do  begin  if massiv=0 then massiv2:=massiv  else  if massiv mod 5 = 0 then massiv2:=massiv*2  else begin  massiv2:=massiv;  massiv2:=massiv2/2;  end;  write(massiv2:0:1,' ');  end;  readln;  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы