Составьте программу,определяющую, является ли данное натуральное число простым. желательно с объяснением
Составьте программу,определяющую, является ли данное натуральное число простым. желательно с объяснением
Ответ(ы) на вопрос:
пусть данное число n
тогда мы будем проверять в цикле все числа от 2 до (n-1) на делимость, если делится => не простое как нибудь это отмечаем
C++ :
int n, i;
bool b=false;
cin>>n;
for (i=2; i
Pascal
program af;
var a,l,k:integer;
begin
read(a);
if a>0 then
k:=0;
for l:=1 to a do
if a mod l = 0 then k:=k+1;
if (k>=1) and (k<=2) then writeln ('Простое') else writeln ('Не простое');
end.
Не нашли ответ?
Похожие вопросы