"среди чисел a,b,c,d найти сумму целых чисел " пожалуйста составьте программу по этой задаче на pascal ABC 

"среди чисел a,b,c,d найти сумму целых чисел " пожалуйста составьте программу по этой задаче на pascal ABC 
Гость
Ответ(ы) на вопрос:
Гость
var   a,b,c,d:real;   s:integer; begin   Write('Введите a b c d: ');  Read(a,b,c,d);   if frac(a)=0 then s:=Trunc(a) else s:=0;   if frac(b)=0 then s:=s+Trunc(b);   if frac(c)=0 then s:=s+Trunc(c);   if frac(d)=0 then s:=s+Trunc(d);   Writeln('S=',s) end. Пример Введите a b c d: 2.5 6 -3 -1.75 S=3
Не нашли ответ?
Ответить на вопрос
Похожие вопросы