Срочно. Нужно написать программу, в которой будет выводиться сумма всех чисел, в которых есть повторяющиеся цифры (например 22,33,44,100,101,202,110,202 и т.д). Так до 10000. Прошу, очень срочно. Можете хоть на паскале, где уго...
Срочно. Нужно написать программу, в которой будет выводиться сумма всех чисел, в которых есть повторяющиеся цифры (например 22,33,44,100,101,202,110,202 и т.д). Так до 10000. Прошу, очень срочно. Можете хоть на паскале, где угодно. Только укажите в своем ответе программу, на которой писали.
Ответ(ы) на вопрос:
Программа на паскале:
var a,c,s:integer;
m:set of 0..9;
b:boolean;
begin
s:=0;
for a:=10 to 10000 do
begin
m:=[];
b:=false;
c:=a;
while c<>0 do
begin
if (c mod 10) in m then b:=true;
m:=m+[c mod 10];
c:=c div 10;
end;
if b then s:=s+a;
end;
writeln('s = ',s);
end.
Результат:
s = 24727105
Не нашли ответ?
Похожие вопросы