СРОЧНО!!! ОЧЕНЬ СРОЧНО! ПОМОГИТЕ.... Дан массив, состоящий из целых чисел. Напишите ?
СРОЧНО!!! ОЧЕНЬ СРОЧНО! ПОМОГИТЕ....
Дан массив, состоящий из целых чисел. Напишите ??рограмму, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.
Входные данные
Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести слово YES, если существует пара соседних элементов с одинаковыми знаками. В противном случае следует вывести слово NO.
Ответ(ы) на вопрос:
Var a:array[1..100000] of integer;
c,i:integer;
Begin
Readln(c);
for i:=1 to c do
if a[i]>0 then inc(c);
Write(c);
End.
Не нашли ответ?
Похожие вопросы