Срочно!! Паскаль! Напишите программу по нахождению всех делителей данного натурального числа
Срочно!! Паскаль! Напишите программу по нахождению всех делителей данного натурального числа
Ответ(ы) на вопрос:
Гость
var
n, i: integer;
begin
readln(n);
i:=n;
writeln('Делители числа ',n,':');
while i>0 do
begin
if (n mod i) = 0 then
write(i, ' ');
i:=i-1;
end;
read;
end.
Не нашли ответ?
Похожие вопросы