СРОЧНО !!! ПОМОГИТЕ !!! Составьте программу вычисления значения выражения для данного натурального числа N: 1²+2²+3²+…+N².
СРОЧНО !!! ПОМОГИТЕ !!!
Составьте программу вычисления значения выражения для данного натурального числа N: 1²+2²+3²+…+N².
Ответ(ы) на вопрос:
Гость
Как ни странно, но задача решается фактически в одну строчку.
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
Writeln(1.To(ReadInteger('N=')).Select(i->i*i).Sum)
end.
Пример
N= 15
1240
Не нашли ответ?
Похожие вопросы