Срочно! Разработать в виде программи алгоритм вычисления взаимного расположения

Срочно! Разработать в виде программи алгоритм вычисления взаимного расположенияточки и прямой(pascal)
Гость
Ответ(ы) на вопрос:
Гость
Uses Crt; var x,y,x1,y1,x2,y2:integer; Begin Clrscr; Writeln('Задайте: x,y,x1,y1,x2,y2'); Readln(x,y,x1,y1,x2,y2); If (abs(x-x1)+abs(x2-x)=abs(x2-x1)) and (abs(y-y1)+(abs(y2-y)=abs(y2-y1)) then Writeln('точка принадлежит отрезку') Else Writelb('точка не пренадлежит отрезку') Readln End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы