СРОЧНО! Составить программу Паскаль z-произведение x, y -случайные числа f- кол-во правильных ответов Если пользователь правильно посчитал, то поздравить его. А если нет, то сказать, что не.
СРОЧНО!
Составить программу Паскаль
z-произведение
x, y -случайные числа
f- кол-во правильных ответов
Если пользователь правильно посчитал, то поздравить его. А если нет, то сказать, что не.
Ответ(ы) на вопрос:
Вместо 20 можно подставить любое число, 20 соответствует M,N
program new;
var a:array [1..20,1..20] of integer; i,j,sum:integer;
begin
randomize;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
a[i,j]:=random(8)-15
end;
end;
for i=2 to 20 do
begin
for j=1 to 20 do
begin
sum:=sum+a[i,j];
i:=i+2;
end;
end;
for i=1 to 20 do
begin
for j=1 to 20 do
begin
write(a[i,j]);
end;
writeln;
end;
writeln('Сумма равна ',sum:8);
end.
P.S.
Делал без паскаля если какие то ошибки то пиши
Не нашли ответ?
Похожие вопросы