Срочноо, помогите!! Напишите программу В ПАСКАЛЕ вычисления выражения: s=x^3+x^5+x^n, где x и n вводятся с клавиатуры. Используйте функцию вычисления степени.
Срочноо, помогите!!
Напишите
программу В ПАСКАЛЕ вычисления выражения: s=x^3+x^5+x^n, где x и n вводятся с клавиатуры. Используйте функцию вычисления
степени.
Ответ(ы) на вопрос:
Гость
Var
X,N:real;
Begin
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
WriteLn('S = ',x*x*x*(1+x*x)+power(x,n));
End.
С помощью функции возведения в степень, при условии, что основание - число вещественное, а показатель - целое.
Function St(O:real;P:integer):real;
Begin
result:=1;
For P:= 1 to P do
result:=result*P;
End;
Var
X:real;
n:integer;
Begin
Write('x = ');
ReadLn(x);
Write('n = ');
ReadLn(n);
WriteLn('S = ',x*x*x*(1+x*x)+St(x,n));
End.
Не нашли ответ?
Похожие вопросы