Требуется написать программу для выставления оценки учащемуся за четверть. Оценка выставляется как среднее арифметическое из 10 полученных оценок. Каждая оценка - случайное число из промежутка от 2 до 5. Использовать массив из ...
Требуется написать программу для выставления оценки учащемуся за четверть. Оценка выставляется как среднее арифметическое из 10 полученных оценок. Каждая оценка - случайное число из промежутка от 2 до 5. Использовать массив из 10 целых чисел.
Ответ(ы) на вопрос:
Гость
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const n = 10;
var a:array[1..n] of integer;
i,k,s:integer;
begin
for i:=1 to 10 do begin
a[i]:=random(2,5); s:=s+a[i];
write(a[i]:4);
end;
writeln;
writeln('Среднее арифметическое оценок = ',s/n:0:1);
end.
Тестовое решение:
5 2 5 2 3 4 5 4 3 5
Среднее арифметическое оценок = 3.8
А уж что поставит учитель - это его решение)
Гость
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
Print('Оценка:',ArrRandom(10,2,5).Println.Average)
end.
Тестовое решение:
3 3 5 2 3 5 3 2 4 4
Оценка: 3.4
Не нашли ответ?
Похожие вопросы