Требуется написать программу при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10 в девятой степени, и выводится произведение цифр этого числа.

Требуется написать программу при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10 в девятой степени, и выводится произведение цифр этого числа.
Гость
Ответ(ы) на вопрос:
Гость
uses crt; var p,n:integer; begin p:=1; write('N='); read(n); while n>0 do begin p:=p*(n mod 10); n:=n div 10; end; writeln('p=',p); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы