Цикл с предусловием Составить программу нахождения частного q и остатка от деления r целого числа х на целое число у, не используя операцию деления.
Цикл с предусловием
Составить программу нахождения частного q и остатка от деления r целого числа х на целое число у, не используя операцию деления.
Ответ(ы) на вопрос:
var
x, y, q, r: integer;
begin
read(x,y);
r := x;
q := 0;
while r >= y do
begin
r := r - y;
q := q + 1
end;
write(q,' ',r)
end.
Не нашли ответ?
Похожие вопросы